Giúp fix lỗi "ERR_TOO_MANY_REDIRECTS"


(Phạm Văn Nghĩa) #1

Nhờ cả nhà giúp mình!
Site wp của mình đang hoạt động bình thường, sau khi cài ssl theo đúng hướng dẫn (https://hocvps.com/cai-dat-lets-encrypt/#cap-nhat-ma-nguon-lets-encrypt-optional) thì vẫn bị dấu CHẤM THAN và bị cả lối ERR_TOO_MANY_REDIRECTS, hiện tại không vào được cả Admin luôn!

  • Vps của mình đang cài hocvps
  • Domain này không phải domain chính của vps (domain chính đã cài thành công ssl vẫn theo hdẫn của bài trên)
  • Mình đã kiểm tra không bị sai url (Mình đã vào database ktra)!
  • Mình đã vào đổi tên tất cả các plugin vẫn ko hết lỗi!
  • Mình không tìm thấy (ko có) file .htaccess

Cảm ơn mọi người!


(dao_tran) #2

post file conf của cái web đó lên miình xem thử


(Việt Phương) #3

Bạn có dùng cloudflare đám mây vàng không
Và bạn đổi tên plugin xong có restart nginx và php-fpm không


(Phạm Văn Nghĩa) #4

Mình không dùng gì clou cả (đổi tên các plugin xong mình ko restart nginx) nhưng mình nghĩ ko phải do plugin vì trước và sau khi bị lỗi mình ko cài mới hay động gì vào plugin nào cả.


(Phạm Văn Nghĩa) #6

Tối mình gửi lên bạn xem hộ nhé, giờ mình đang ở cty, ths


(Phạm Văn Nghĩa) #7

Nội dung file conf của domain mình đây bạn nhé, bạn xem giúp mình với, cảm ơn bạn!

      server {
	listen 443 ssl;
	server_name www.Mydomain.com;

	# SSL
	ssl_certificate /etc/letsencrypt/live/Mydomain.com/fullchain.pem;
	ssl_certificate_key /etc/letsencrypt/live/Mydomain.com/privkey.pem;
	ssl_protocols TLSv1 TLSv1.1 TLSv1.2; 
	ssl_prefer_server_ciphers on; 
	ssl_ciphers EECDH+CHACHA20:EECDH+AES128:RSA+AES128:EECDH+AES256:RSA+AES256:EECDH+3DES:RSA+3DES:!MD5;

	rewrite ^(.*) https://Mydomain.com$1 permanent;
}
server {
	server_name Mydomain.com www.Mydomain.com;
	rewrite ^(.*) https://Mydomain.com$1 permanent;
    	}
server {
	listen 443 ssl;

    	access_log off;
	# access_log /home//logs/access.log;
    	error_log off;
    	# error_log /home/Mydomain.com/logs/error.log;
    	root /home/Mydomain.com/public_html;
	index index.php index.html index.htm;
    	server_name Mydomain.com;
# SSL
	ssl_certificate /etc/letsencrypt/live/Mydomain.com/fullchain.pem;
	ssl_certificate_key /etc/letsencrypt/live/Mydomain.com/privkey.pem;
	ssl_protocols TLSv1 TLSv1.1 TLSv1.2; 
	ssl_prefer_server_ciphers on; 
	ssl_ciphers EECDH+CHACHA20:EECDH+AES128:RSA+AES128:EECDH+AES256:RSA+AES256:EECDH+3DES:RSA+3DES:!MD5;

        # Improve HTTPS performance with session resumption
        ssl_session_cache shared:SSL:50m;
        ssl_session_timeout 1d;

        # DH parameters
        ssl_dhparam /etc/nginx/ssl/dhparam.pem;
        # Enable HSTS
        add_header Strict-Transport-Security "max-age=31536000" always;
 
    	location / {
		try_files $uri $uri/ /index.php?$args;
	}
 
    	location ~ \.php$ {
		fastcgi_split_path_info ^(.+\.php)(/.+)$;
        	include /etc/nginx/fastcgi_params;
        	fastcgi_pass 127.0.0.1:9000;
        	fastcgi_index index.php;
		fastcgi_connect_timeout 300;
		fastcgi_send_timeout 300;
		fastcgi_read_timeout 300;
		fastcgi_buffer_size 32k;
		fastcgi_buffers 8 16k;
		fastcgi_busy_buffers_size 32k;
		fastcgi_temp_file_write_size 32k;
		fastcgi_intercept_errors on;
        	fastcgi_param SCRIPT_FILENAME /home/Mydomain.com/public_html$fastcgi_script_name;
    	}
	location ~ /\. {
		deny all;
	}
	location = /favicon.ico {
		log_not_found off;
		access_log off;
	}
	location = /robots.txt {
		allow all;
		log_not_found off;
		access_log off;
	}
	location ~* \.(3gp|gif|jpg|jpeg|png|ico|wmv|avi|asf|asx|mpg|mpeg|mp4|pls|mp3|mid|wav|swf|flv|exe|zip|tar|rar|gz|tgz|bz2|uha|7z|doc|docx|xls|xlsx|pdf|iso|eot|svg|ttf|woff)$ {
		gzip_static off;
		add_header Pragma public;
		add_header Cache-Control "public, must-revalidate, proxy-revalidate";
		access_log off;
		expires 30d;
		break;
        }

        location ~* \.(txt|js|css)$ {
	        add_header Pragma public;
		add_header Cache-Control "public, must-revalidate, proxy-revalidate";
		access_log off;
		expires 30d;
		break;
        }
    }
`

(dao_tran) #8

đây chỉ là conf cho 1 website sao bạn lại dùng tới 2 block server listen 443, còn một block server vẫn chưa định nghĩa listen cho nó.


(Phạm Văn Nghĩa) #9

Vì mình làm theo hướng dẫn mà

Cậu cho mình xin ndung chuẩn của file đó với


(dao_tran) #10

bạn dùng cái này

server {
listen 80;
server_name Mydomain.com www.Mydomain.com;
rewrite ^(.*) https://Mydomain.com$1 permanent;
}
server {
listen 443 ssl;
access_log off;
# access_log /home//logs/access.log;
error_log off;
# error_log /home/Mydomain.com/logs/error.log;
root /home/Mydomain.com/public_html;
index index.php index.html index.htm;
server_name Mydomain.com;
# SSL
ssl_certificate /etc/letsencrypt/live/Mydomain.com/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/Mydomain.com/privkey.pem;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_prefer_server_ciphers on;
ssl_ciphers EECDH+CHACHA20:EECDH+AES128:RSA+AES128:EECDH+AES256:RSA+AES256:EECDH+3DES:RSA+3DES:!MD5;
# Improve HTTPS performance with session resumption
ssl_session_cache shared:SSL:50m;
ssl_session_timeout 1d;
# DH parameters
ssl_dhparam /etc/nginx/ssl/dhparam.pem;
# Enable HSTS
add_header Strict-Transport-Security “max-age=31536000” always;

	location / {
	try_files $uri $uri/ /index.php?$args;
}

	location ~ \.php$ {
	fastcgi_split_path_info ^(.+\.php)(/.+)$;
    	include /etc/nginx/fastcgi_params;
    	fastcgi_pass 127.0.0.1:9000;
    	fastcgi_index index.php;
	fastcgi_connect_timeout 300;
	fastcgi_send_timeout 300;
	fastcgi_read_timeout 300;
	fastcgi_buffer_size 32k;
	fastcgi_buffers 8 16k;
	fastcgi_busy_buffers_size 32k;
	fastcgi_temp_file_write_size 32k;
	fastcgi_intercept_errors on;
    	fastcgi_param SCRIPT_FILENAME /home/Mydomain.com/public_html$fastcgi_script_name;
	}
location ~ /\. {
	deny all;
}
location = /favicon.ico {
	log_not_found off;
	access_log off;
}
location = /robots.txt {
	allow all;
	log_not_found off;
	access_log off;
}
location ~* \.(3gp|gif|jpg|jpeg|png|ico|wmv|avi|asf|asx|mpg|mpeg|mp4|pls|mp3|mid|wav|swf|flv|exe|zip|tar|rar|gz|tgz|bz2|uha|7z|doc|docx|xls|xlsx|pdf|iso|eot|svg|ttf|woff)$ {
	gzip_static off;
	add_header Pragma public;
	add_header Cache-Control "public, must-revalidate, proxy-revalidate";
	access_log off;
	expires 30d;
	break;
    }

    location ~* \.(txt|js|css)$ {
        add_header Pragma public;
	add_header Cache-Control "public, must-revalidate, proxy-revalidate";
	access_log off;
	expires 30d;
	break;
    }
}

nếu vẫn chưa được thì bạn xóa cáu hình ssl đi, đổi cấu hình này trở về thành chạy http, cho web chạy ok đi rồi làm lại ssl lẫn nữa.
nếu vẫn chưa được mình ssh vào xem qua cho


(Phạm Văn Nghĩa) #11

Cảm ơn bạn, để mình thử


(Phạm Văn Nghĩa) #12

Mình đã thay nội dung file như của bạn nhưng vẫn không có gì thay đổi cả bạn ơi!

Mình vừa nhắn cho bạn qua skype, bạn check giùm mình nhé! ths