Lỗi 403 forbidden Nginx


(Khánh) #1

Sau khi em up code web lên VPS xong xuôi. Em vào domain:point/phpmyadmin khi đăng nhập vào nó tự 301 về 1 tên miền đã up lên vps và thông báo lỗi 403 forbidden
AE tron này ai biết sửa lỗi này giúp e với ạ


(Việt Phương) #2

Cung cấp mình Nginx Conf của domain chính cài HocVPS


(Khánh) #3

360dogame.com nó tự 301 về cái này ạ?
Còn cái chính e cài thì e dùng cái này http://non-www


(Khánh) #4

server {
listen 80;

server_name non-www;
rewrite ^(.*) http://non-www$1 permanent;

}
server {
listen 80 default_server;

# access_log off;
access_log /home/non-www/logs/access.log;
# error_log off;
	error_log /home/non-www/logs/error.log;

	root /home/non-www/public_html;
index index.php index.html index.htm;
	server_name non-www;

	location / {
	try_files $uri $uri/ /index.php?$args;
}

# Custom configuration
include /home/non-www/public_html/*.conf;

	location ~ \.php$ {
	fastcgi_split_path_info ^(.+\.php)(/.+)$;
    	include /etc/nginx/fastcgi_params;
    	fastcgi_pass 127.0.0.1:9000;
    	fastcgi_index index.php;
	fastcgi_connect_timeout 1000;
	fastcgi_send_timeout 1000;
	fastcgi_read_timeout 1000;
	fastcgi_buffer_size 256k;
	fastcgi_buffers 4 256k;
	fastcgi_busy_buffers_size 256k;
	fastcgi_temp_file_write_size 256k;
	fastcgi_intercept_errors on;
    	fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
	}

location /nginx_status {
	stub_status on;
	access_log   off;
	allow 127.0.0.1;
	allow 149.28.226.12;
	deny all;
}

location /php_status {
	fastcgi_pass 127.0.0.1:9000;
	fastcgi_index index.php;
	fastcgi_param SCRIPT_FILENAME  $document_root$fastcgi_script_name;
	include /etc/nginx/fastcgi_params;
	allow 127.0.0.1;
	allow 149.28.226.12;
	deny all;
	}

# Disable .htaccess and other hidden files
location ~ /\.(?!well-known).* {
	deny all;
	access_log off;
	log_not_found off;
}

    location = /favicon.ico {
            log_not_found off;
            access_log off;
    }

location = /robots.txt {
	allow all;
	log_not_found off;
	access_log off;
}

location ~* \.(3gp|gif|jpg|jpeg|png|ico|wmv|avi|asf|asx|mpg|mpeg|mp4|pls|mp3|mid|wav|swf|flv|exe|zip|tar|rar|gz|tgz|bz2|uha|7z|doc|docx|xls|xlsx|pdf|iso|eot|svg|ttf|woff)$ {
        gzip_static off;
	add_header Pragma public;
	add_header Cache-Control "public, must-revalidate, proxy-revalidate";
	access_log off;
	expires 30d;
	break;
    }

    location ~* \.(txt|js|css)$ {
        add_header Pragma public;
	add_header Cache-Control "public, must-revalidate, proxy-revalidate";
	access_log off;
	expires 30d;
	break;
    }

}

server {
listen 2018;

access_log off;
log_not_found off;
error_log /home/non-www/logs/nginx_error.log;

	root /home/non-www/private_html;
index index.php index.html index.htm;
	server_name non-www;

auth_basic "Restricted";
auth_basic_user_file /home/non-www/private_html/hocvps/.htpasswd;

 	location / {
	autoindex on;
	try_files $uri $uri/ /index.php;
}

	location ~ \.php$ {
	fastcgi_split_path_info ^(.+\.php)(/.+)$;
    	include /etc/nginx/fastcgi_params;
    	fastcgi_pass 127.0.0.1:9000;
    	fastcgi_index index.php;
	fastcgi_connect_timeout 1000;
	fastcgi_send_timeout 1000;
	fastcgi_read_timeout 1000;
	fastcgi_buffer_size 256k;
	fastcgi_buffers 4 256k;
	fastcgi_busy_buffers_size 256k;
	fastcgi_temp_file_write_size 256k;
	fastcgi_intercept_errors on;
    	fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
	}

location ~ /\. {
	deny all;
}

}

ĐÂY Ạ


(Việt Phương) #5

Domain kia thì bạn truy cập qua ip:port chứ?


(Khánh) #6

Đúng rồi bạn. Mà up đc 4 cái web lên rồi. Giờ cái thứ 5 thì lại bị thế này :frowning:


(Việt Phương) #7

Bạn bỏ cái default_server ở Nginx Conf domain 360dogame chưa?
Nếu chưa, bỏ và restart lại Nginx
Đồng thời domain 360dogame không được cài phần block HocVPS (block 2018)


(Khánh) #8

Em ko thấy cái default sever. Bác ơi. Bác có online ko cho e skyper với ạ. E có thể chát trực tiếp với bác đc ko?


(Việt Phương) #9

Tốt nhất, bạn cung cấp các Nginx Conf của các domain liên quan đến vấn đề
Paste qua https://pastebin.com/ cho gọn
Chat thì trong diễn đàn có mục gửi tin nhắn đó bạn