Lỗi không vào được phpmyadmin


(Viet) #1

Các bác giúp e với , e không vào được phpmyadmin sau khi từ lúc lên HTTPS. Nó báo “Không thể truy cập trang web này”. Trước đó dùng HTTP thì vẫn truy cập được bình thường. Bác nào giúp em với. E dùng vps của myvulrt


(Việt Phương) #2

Bạn dùng HocVPS? Cho mình Nginx Conf của domain bạn đã cài HTTPS


(Viet) #3

Đây bạn ah

server {
listen 80;
server_name hocpianoonline.com www.hocpianoonline.com;
return 301 https://$server_name$request_uri;
}
server {
listen 443 spdy ssl;
server_name hocpianoonline.com www.hocpianoonline.com;
keepalive_timeout 30;

ssl on;
ssl_certificate /etc/ssl/hocpianoonline_com.crt;
ssl_certificate_key /etc/ssl/hocpianoonline.com.key;
ssl_session_timeout 5m;
ssl_session_cache shared:SSL:10m;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_ciphers “ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA256:ECDHE-RSA-AES256-SHA:ECDHE-RSA-AES128-SHA:DHE-RSA-AES256-SHA256:DHE-RSA-AES128-SHA256:DHE-RSA-AES256-SHA:DHE-RSA-AES128-SHA:ECDHE-RSA-DES-CBC3-SHA:EDH-RSA-DES-CBC3-SHA:AES256-GCM-SHA384:AES128-GCM-SHA256:AES256-SHA256:AES128-SHA256:AES256-SHA:AES128-SHA:DES-CBC3-SHA:HIGH:!aNULL:!eNULL:!EXPORT:!DES:!MD5:!PSK:!RC4”;
ssl_prefer_server_ciphers on;
add_header Strict-Transport-Security “max-age=31536000; includeSubdomains;”;
ssl_stapling on;
root /home/hocpianoonline.com/public_html;

location / {
index index.php index.html index.htm;
try_files $uri $uri/ /index.php?$uri&$args;

access_log off;

access_log /home//logs/access.log;

error_log off;

error_log /home/hocpianoonline.com/logs/error.log;

root /home/hocpianoonline.com/public_html;
index index.php index.html index.htm;

location / {
try_files $uri $uri/ /index.php?$args;
}

location ~ .php$ {
fastcgi_split_path_info ^(.+.php)(/.+)$;
include /etc/nginx/fastcgi_params;
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
fastcgi_connect_timeout 300;
fastcgi_send_timeout 300;
fastcgi_read_timeout 300;
fastcgi_buffer_size 32k;
fastcgi_buffers 8 16k;
fastcgi_busy_buffers_size 32k;
fastcgi_temp_file_write_size 32k;
fastcgi_intercept_errors on;
fastcgi_param SCRIPT_FILENAME /home/hocpianoonline.com/public_html$fastcgi_script_name;
}
location ~ /. {
deny all;
}
location = /favicon.ico {
log_not_found off;
access_log off;
}
location = /robots.txt {
allow all;
log_not_found off;
access_log off;
}
location ~* .(3gp|gif|jpg|jpeg|png|ico|wmv|avi|asf|asx|mpg|mpeg|mp4|pls|mp3|mid|wav|swf|flv|exe|zip|tar|rar|gz|tgz|bz2|uha|7z|doc|docx|xls|xlsx|pdf|iso|eot|svg|ttf|woff)$ {
gzip_static off;
add_header Pragma public;
add_header Cache-Control “public, must-revalidate, proxy-revalidate”;
access_log off;
expires 30d;
break;
}

location ~* .(txt|js|css)$ {
add_header Pragma public;
add_header Cache-Control “public, must-revalidate, proxy-revalidate”;
access_log off;
expires 30d;
break;
}
}
}

Blockquote


(Việt Phương) #4

Oh, bạn cài SSL theo hướng dẫn nào mà lạ vậy.
Với cả không phải file này. File cấu hình liên quan cả PHPMyAdmin cơ
Bạn dùng hệ thống gì? HocVPS thì là của domain chính, còn hệ thống khác thì bạn cần tìm cấu hình Webserver liên quan đến PHPMyAdmin
Và bạn đăng nhập PHPMyAdmin hiện thông báo gì?


(Viet) #5

Cái hôm mình tìm SSL theo trên mạng ở trên thachpham thì phải. Còn file nginx gốc thì mình có copy để để phòng.
Mình vào phpmyadmin thì nó báo lỗi không thể kết nối tới máy chủ.


(Viet) #6

Bạn cho mình link FB trao đổi đc k


(Việt Phương) #7
  1. Nếu bạn dùng HocVPS thì bạn cài theo hướng dẫn của HocVPS ý, hoặc nếu bạn dùng hướng dẫn thachpham thì chỉ chèn và thay đổi phần cần thay đổi, ngoài ra các phần khác phải giữ nguyên
    Trong trường hợp này, bạn đã xóa block cấu hình HocVPS Admin
  2. Nếu không phải HocVPS thì hiện tại bạn đang dùng hệ quản trị gì

(Viet) #8

Hic chào bác. Tính hình là e dùng theo của hoc vps. Cụ thể là e cài theo link này. https://hocvps.com/cai-dat-chung-chi-ssl/ sau khi làm xong thì ở dưới ghi là
Lúc này link login HocVPS Script Admin sẽ là https://canhme.com:2018, không sử dụng IP nữa. nhưng e vào theo cũng không được ạ. Đây là đoạn file của em bác xem giúp em

server {
listen 443 ssl;
server_name www.hocpianoonline.com;

# SSL
    ssl_certificate /etc/ssl/hocpianoonline_com.crt;
    ssl_certificate_key /etc/ssl/hocpianoonline.com.key;
    ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
    ssl_prefer_server_ciphers on;
ssl_ciphers 'ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA:ECDHE-RSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-RSA-AES256-SHA256:DHE-RSA-AES256-SHA:ECDHE-ECDSA-DES-CBC3-SHA:ECDHE-RSA-DES-CBC3-SHA:EDH-RSA-DES-CBC3-SHA:AES128-GCM-SHA256:AES256-GCM-SHA384:AES128-SHA256:AES256-SHA256:AES128-SHA:AES256-SHA:DES-CBC3-SHA:!DSS';
rewrite ^(.*) https://hocpianoonline.com$1 permanent;

}

server {
listen 80;

server_name hocpianoonline.com www.hocpianoonline.com;
rewrite ^(.*) https://hocpianoonline.com$1 permanent;

}

server {
listen 443 ssl default_server;

# access_log off;
access_log /home/hocpianoonline.com/logs/access.log;
# error_log off;
	error_log /home/hocpianoonline.com/logs/error.log;

	root /home/hocpianoonline.com/public_html;
index index.php index.html index.htm;
	server_name hocpianoonline.com;
	
	# SSL
    ssl_certificate /etc/ssl/hocpianoonline_com.crt;
    ssl_certificate_key /etc/ssl/hocpianoonline.com.key;
    ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
    ssl_prefer_server_ciphers on;
ssl_ciphers 'ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA:ECDHE-RSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-RSA-AES256-SHA256:DHE-RSA-AES256-SHA:ECDHE-ECDSA-DES-CBC3-SHA:ECDHE-RSA-DES-CBC3-SHA:EDH-RSA-DES-CBC3-SHA:AES128-GCM-SHA256:AES256-GCM-SHA384:AES128-SHA256:AES256-SHA256:AES128-SHA:AES256-SHA:DES-CBC3-SHA:!DSS';

    # Improve HTTPS performance with session resumption
    ssl_session_cache shared:SSL:50m;
    ssl_session_timeout 1d;
  
    # DH parameters
    ssl_dhparam /etc/nginx/ssl/dhparam.pem;

    # Enable HSTS
    add_header Strict-Transport-Security "max-age=31536000" always;

	location / {
	try_files $uri $uri/ /index.php?$args;
}

# Custom configuration
include /home/hocpianoonline.com/public_html/*.conf;

	location ~ \.php$ {
	fastcgi_split_path_info ^(.+\.php)(/.+)$;
    	include /etc/nginx/fastcgi_params;
    	fastcgi_pass 127.0.0.1:9000;
    	fastcgi_index index.php;
	fastcgi_connect_timeout 1000;
	fastcgi_send_timeout 1000;
	fastcgi_read_timeout 1000;
	fastcgi_buffer_size 256k;
	fastcgi_buffers 4 256k;
	fastcgi_busy_buffers_size 256k;
	fastcgi_temp_file_write_size 256k;
	fastcgi_intercept_errors on;
    	fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
	}

location /nginx_status {
	stub_status on;
	access_log   off;
	allow 127.0.0.1;
	allow 45.77.23.226;
	deny all;
}

location /php_status {
	fastcgi_pass 127.0.0.1:9000;
	fastcgi_index index.php;
	fastcgi_param SCRIPT_FILENAME  $document_root$fastcgi_script_name;
	include /etc/nginx/fastcgi_params;
	allow 127.0.0.1;
	allow 45.77.23.226;
	deny all;
	}

# Disable .htaccess and other hidden files
location ~ /\.(?!well-known).* {
	deny all;
	access_log off;
	log_not_found off;
}

    location = /favicon.ico {
            log_not_found off;
            access_log off;
    }

location = /robots.txt {
	allow all;
	log_not_found off;
	access_log off;
}

location ~* \.(3gp|gif|jpg|jpeg|png|ico|wmv|avi|asf|asx|mpg|mpeg|mp4|pls|mp3|mid|wav|swf|flv|exe|zip|tar|rar|gz|tgz|bz2|uha|7z|doc|docx|xls|xlsx|pdf|iso|eot|svg|ttf|woff)$ {
        gzip_static off;
	add_header Pragma public;
	add_header Cache-Control "public, must-revalidate, proxy-revalidate";
	access_log off;
	expires 30d;
	break;
    }

    location ~* \.(txt|js|css)$ {
        add_header Pragma public;
	add_header Cache-Control "public, must-revalidate, proxy-revalidate";
	access_log off;
	expires 30d;
	break;
    }

}

server {
listen 2018 ssl;

access_log off;
log_not_found off;
error_log /home/hocpianoonline.com/logs/nginx_error.log;

	root /home/hocpianoonline.com/private_html;
index index.php index.html index.htm;
	server_name hocpianoonline.com;
	
	 error_page 497 https://$server_name:$server_port$request_uri;

    # SSL
    ssl_certificate /etc/ssl/hocpianoonline_com.crt;
    ssl_certificate_key /etc/ssl/hocpianoonline.com.key;
    ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
    ssl_prefer_server_ciphers on;
ssl_ciphers 'ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA:ECDHE-RSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-RSA-AES256-SHA256:DHE-RSA-AES256-SHA:ECDHE-ECDSA-DES-CBC3-SHA:ECDHE-RSA-DES-CBC3-SHA:EDH-RSA-DES-CBC3-SHA:AES128-GCM-SHA256:AES256-GCM-SHA384:AES128-SHA256:AES256-SHA256:AES128-SHA:AES256-SHA:DES-CBC3-SHA:!DSS';

auth_basic "Restricted";
auth_basic_user_file /home/hocpianoonline.com/private_html/hocvps/.htpasswd;

 	location / {
	autoindex on;
	try_files $uri $uri/ /index.php;
}

	location ~ \.php$ {
	fastcgi_split_path_info ^(.+\.php)(/.+)$;
    	include /etc/nginx/fastcgi_params;
    	fastcgi_pass 127.0.0.1:9000;
    	fastcgi_index index.php;
	fastcgi_connect_timeout 1000;
	fastcgi_send_timeout 1000;
	fastcgi_read_timeout 1000;
	fastcgi_buffer_size 256k;
	fastcgi_buffers 4 256k;
	fastcgi_busy_buffers_size 256k;
	fastcgi_temp_file_write_size 256k;
	fastcgi_intercept_errors on;
    	fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
	}

location ~ /\. {
	deny all;
}

}


(Việt Phương) #10

Bạn dùng Cloudflare CDN nên đọc phần chú ý dành cho CF CDN trong bài viết hướng dẫn nhé
https://hocvps.com/cai-dat-chung-chi-ssl/


(Viet) #11

Ok bác e làm được rồi. Cảm ơn bác nhé.
Mà bác cho e hỏi thêm là hiện site e mua SSL cho mỗi domain chính. E tạo thêm subdomain để làm 1 site khác nhưng nó toàn chuyển hướng tới site chính. Vậy làm cách nào để tắt được cái đó ạ, subdomain e không cần SSL


(Việt Phương) #12

nginx -t của bạn ra kết quả gì?


(Viet) #13

nó báo thành công bác ạ

nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful


(Việt Phương) #14

Bạn restart Nginx xem được không?
Nếu vẫn không được thì cung cấp mình toàn bộ các Nginx Conf trong /etc/nginx/conf.d
Paste qua https://pastebin.com/ cho gọn


(Tuan Anh) #15

Vào một ngày đẹp trời em không thể truy cập được phpmyadmin.
Mặc dù đã restart mysql, restart lại server. Website vẫn truy cập được bình thường.
Sau khi nhập user và pass báo lỗi với nội dung sau :
" domain.com is currently unable to handle this request.
HTTP ERROR 500 "
Có ai chỉ giúp em với