Không vào được phpmyadmin sau khi cài SSL


(Ngọc Linh) #1

Sau khi cài xong HOCVPS, em vào phpmyadmin qua đường link: http://[ip]:[port]/phpmyadmin. Vào bình thường. hoặc http://domain:[port]/phpmyadmin đều được

Sau khi cài xong SSL cho 1 domain, thì không thể nào vào lại được phpmyadmin nữa. Em đã thử các cách sau và đều ra chung 1 kết quả:
http://[ip]:[port]/phpmyadmin
http://domain:[port]/phpmyadmin
https://domain:[port]/phpmyadmin
Thậm chí, add thêm tên miền khác, không dùng ssl, cũng pó tay luôn.
(Không thể truy cập trang này
…đã từ chối kết nối.
Hãy thử:
Kiểm tra kết nối
Kiểm tra proxy và tường lửa
ERR_CONNECTION_REFUSED).
Ai biết xin chỉ dùm cho ah. Cám ơn các tiền bối !


(Việt Phương) #2

Cho mình nginx conf của domain bạn cài ssl
Và domain đó là domain chính hay phụ cài HocVPS


(Ngọc Linh) #3

server {
listen 80;
server_name zeeuni.com www.zeeuni.com;
rewrite ^(.*) https://zeeuni.com$1 permanent;
return 301 https://$server_name$request_uri;
}

server {
listen 443 ssl http2;
ssl_certificate /etc/nginx/ssl/csr/zeeuni_com.crt;
ssl_certificate_key /etc/nginx/ssl/private/zeeuni.com.key;
ssl_dhparam /etc/nginx/ssl/private/dhparam.pem;
ssl_session_cache shared:SSL:20m;
ssl_session_tickets off;
ssl_session_timeout 20m;
ssl_prefer_server_ciphers on;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_ciphers ‘ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:kEDH+AESGCM:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA:ECDHE-ECDSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-RSA-AES256-SHA256:DHE-DSS-AES256-SHA:AES128-GCM-SHA256:AES256-GCM-SHA384:HIGH:!aNULL:!eNULL:!EXPORT:!DES:!3DES:!MD5:!PSK’;
ssl_stapling on;
ssl_stapling_verify on;
resolver 8.8.4.4 8.8.8.8 valid=300s;
resolver_timeout 5s;
ssl_trusted_certificate /etc/nginx/ssl/csr/zeeuni_com.crt;
add_header Strict-Transport-Security max-age=31536000;
error_log off;
# error_log /home/zeeuni.com/logs/error.log;
root /home/zeeuni.com/public_html;
index index.php index.html index.htm;
server_name zeeuni.com;

 location / {

try_files $uri $uri/ /index.php?$args;
}

Custom configuration

include /home/zeeuni.com/public_html/*.conf;

 location ~ \.php$ {

fastcgi_split_path_info ^(.+.php)(/.+)$;
include /etc/nginx/fastcgi_params;
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
fastcgi_connect_timeout 300;
fastcgi_send_timeout 300;
fastcgi_read_timeout 300;
fastcgi_buffer_size 32k;
fastcgi_buffers 8 16k;
fastcgi_busy_buffers_size 32k;
fastcgi_temp_file_write_size 32k;
fastcgi_intercept_errors on;
fastcgi_param SCRIPT_FILENAME /home/zeeuni.com/public_html$fastcgi_script_name;
}
location ~ /. {
deny all;
}
location = /favicon.ico {
log_not_found off;
access_log off;
}
location = /robots.txt {
allow all;
log_not_found off;
access_log off;
}
location ~* .(3gp|gif|jpg|jpeg|png|ico|wmv|avi|asf|asx|mpg|mpeg|mp4|pls|mp3|mid|wav|swf|flv|exe|zip|tar|rar|gz|tgz|bz2|uha|7z|doc|docx|xls|xlsx|pdf|iso|eot|svg|ttf|woff)$ {
gzip_static off;
add_header Pragma public;
add_header Cache-Control “public, must-revalidate, proxy-revalidate”;
access_log off;
expires 30d;
break;
}

    location ~* \.(txt|js|css)$ {
     add_header Pragma public;

add_header Cache-Control “public, must-revalidate, proxy-revalidate”;
access_log off;
expires 30d;
break;
}
}

Đây là domain chính. Cài xong SSL thì ko vào được phpmyadmin bằng domain này nữa. qua IP VPS hay dùng domain phụ không SSL cũng pó tay. Mong bạn giúp đỡ dùm ah


(Việt Phương) #4

Bạn theo hướng dẫn bên nào vậy? Chuẩn đyâ mà
https://hocvps.com/cai-dat-chung-chi-ssl/
Như bạn thì bạn xóa block server chứa HocVPS Port đi rồi nên nó không truy cập được là đúng


(Ngọc Linh) #5

Mình làm theo hướng dẫn này:


SSL mình cũng mua của namecheap, nên làm theo hướng dẫn này thì mình còn làm được ^^. Mình chỉ là dân vọc, nên chỉ sao làm vậy được thôi ^^.
Hay bạn có thể giúp mình sửa lại file này như thế nào cho đúng được không ah. Cám ơn bạn nhiều


(Ngọc Linh) #6

Bạn ơi, Admin của thichviet.net (CuongPJH) đã hỗ trợ cho mình được rồi. Cám ơn bạn đã nhiệt tình giúp đỡ nhé !


(Việt Phương) #7

OH bạn. chú ý là cài SSL hay cấu hình Nginx thì thêm/bỏ thứ gì cần thôi chứ đừng xóa toàn bộ xong thay bằng phần khác, như thế dễ xung đột với cấu hình gốc của script


(Duy) #8

Phương ơi mình cũng bị tương tự cái này rồi. K hiểu block port kiểu gì giờ k vào đc luôn. Làm đúng theo hướng dẫn ở bài kia mà :((


(Việt Phương) #9

Cho mình Nginx Conf của domain chính


(Duy) #10

Mình khắc phục được rồi. Hóa ra chắc do lỗi trong quá trình chỉnh sửa file conf k tuân theo thứ tự gì đó.
M vào hocvps xóa domain, chạy lại lệnh cài ssl, vào lấy cái file conf domain khác chép vào domain mới rồi replace địa chỉ domain mới, khởi động lại nginx là xong :slight_smile:


(Trọng Đức) #11

Mình bị mất pass admin của wordpress, giờ cần vào phpmyadmin để set lại pass mới biết là không vào được. website vẫn chạy mình thường.
Đây là cấu hình nginx của mình. Bạn check dùm mình lỗi ở đâu nha. Sử dụng hocvps script

server {
listen 443 ssl;
server_name www.hongthu.com;

# SSL
ssl_certificate /etc/letsencrypt/live/hongthu.com/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/hongthu.com/privkey.pem;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2; 
ssl_prefer_server_ciphers on; 
ssl_ciphers EECDH+CHACHA20:EECDH+AES128:RSA+AES128:EECDH+AES256:RSA+AES256:EECDH+3DES:RSA+3DES:!MD5;

rewrite ^(.*) https://hongthu.com$1 permanent;

}
server {
listen 80;
server_name hongthu.com www.hongthu.com;
rewrite ^(.*) https://hongthu.com$1 permanent;
}

server {
listen 443 ssl default_server;

# access_log off;
access_log /home/hongthu.com/logs/access.log;
# error_log off;
	error_log /home/hongthu.com/logs/error.log;

	root /home/hongthu.com/public_html;
index index.php index.html index.htm;
	server_name hongthu.com;

# SSL
ssl_certificate /etc/letsencrypt/live/hongthu.com/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/hongthu.com/privkey.pem;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2; 
ssl_prefer_server_ciphers on; 
ssl_ciphers EECDH+CHACHA20:EECDH+AES128:RSA+AES128:EECDH+AES256:RSA+AES256:EECDH+3DES:RSA+3DES:!MD5;

    # Improve HTTPS performance with session resumption
    ssl_session_cache shared:SSL:50m;
    ssl_session_timeout 1d;

    # DH parameters
    ssl_dhparam /etc/nginx/ssl/dhparam.pem;
    # Enable HSTS
    add_header Strict-Transport-Security "max-age=31536000" always;

	location / {
	try_files $uri $uri/ /index.php?$args;
}

# Custom configuration
include /home/hongthu.com/public_html/*.conf;

	location ~ \.php$ {
	fastcgi_split_path_info ^(.+\.php)(/.+)$;
    	include /etc/nginx/fastcgi_params;
    	fastcgi_pass 127.0.0.1:9000;
    	fastcgi_index index.php;
	fastcgi_connect_timeout 1000;
	fastcgi_send_timeout 1000;
	fastcgi_read_timeout 1000;
	fastcgi_buffer_size 256k;
	fastcgi_buffers 4 256k;
	fastcgi_busy_buffers_size 256k;
	fastcgi_temp_file_write_size 256k;
	fastcgi_intercept_errors on;
    	fastcgi_param SCRIPT_FILENAME /home/hongthu.com/public_html$fastcgi_script_name;
	}
location /nginx_status {
	stub_status on;
	access_log   off;
            allow 127.0.0.1;
            deny all;
}
location /php_status {
	fastcgi_pass 127.0.0.1:9000;
	fastcgi_index index.php;
	fastcgi_param SCRIPT_FILENAME  /home/hongthu.com/public_html$fastcgi_script_name;
	include /etc/nginx/fastcgi_params;
            allow 127.0.0.1;
            deny all;
	}
# Disable .htaccess and other hidden files
location ~ /\.(?!well-known).* {
	deny all;
	access_log off;
	log_not_found off;
}
    location = /favicon.ico {
            log_not_found off;
            access_log off;
    }
    location = /robots.txt {
            allow all;
            log_not_found off;
            access_log off;
    }
location ~* \.(3gp|gif|jpg|jpeg|png|ico|wmv|avi|asf|asx|mpg|mpeg|mp4|pls|mp3|mid|wav|swf|flv|exe|zip|tar|rar|gz|tgz|bz2|uha|7z|doc|docx|xls|xlsx|pdf|iso|eot|svg|ttf|woff)$ {
        gzip_static off;
	add_header Pragma public;
	add_header Cache-Control "public, must-revalidate, proxy-revalidate";
	access_log off;
	expires 30d;
	break;
    }

    location ~* \.(txt|js|css)$ {
        add_header Pragma public;
	add_header Cache-Control "public, must-revalidate, proxy-revalidate";
	access_log off;
	expires 30d;
	break;
    }

}

server {
listen 2018 ssl;

access_log        off;
log_not_found     off;
error_log /home/hongthu.com/logs/nginx_error.log;

	root /home/hongthu.com/private_html;
index index.php index.html index.htm;
	server_name hongthu.com;

    error_page 497 https://$server_name:2018$request_uri;

ssl_certificate /etc/letsencrypt/live/hongthu.com/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/hongthu.com/privkey.pem;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2; 
ssl_prefer_server_ciphers on; 
ssl_ciphers EECDH+CHACHA20:EECDH+AES128:RSA+AES128:EECDH+AES256:RSA+AES256:EECDH+3DES:RSA+3DES:!MD5;

auth_basic "Restricted";
auth_basic_user_file /home/hongthu.com/private_html/hocvps/.htpasswd;

 	location / {
	autoindex on;
	try_files $uri $uri/ /index.php;
}

	location ~ \.php$ {
	fastcgi_split_path_info ^(.+\.php)(/.+)$;
    	include /etc/nginx/fastcgi_params;
    	fastcgi_pass 127.0.0.1:9000;
    	fastcgi_index index.php;
	fastcgi_connect_timeout 1000;
	fastcgi_send_timeout 1000;
	fastcgi_read_timeout 1000;
	fastcgi_buffer_size 256k;
	fastcgi_buffers 4 256k;
	fastcgi_busy_buffers_size 256k;
	fastcgi_temp_file_write_size 256k;
	fastcgi_intercept_errors on;
    	fastcgi_param SCRIPT_FILENAME /home/hongthu.com/private_html$fastcgi_script_name;
	}

location ~ /\. {
	deny all;
}

}

=======
Cảm ơn hocvps trước


(Viet) #12

Bạn ơi mình cũng bị như bạn. Làm cách nào khắc phục vậy ạ


(Việt Phương) #13

Tùy từng lỗi. Case bạn trên là về sửa port
Case bạn lỗi cụ thể như thế nào? Bạn post Nginx Conf của domain đã cài SSL ra nhé