Cho mình hỏi về Park Domain hocvps script


(Suke Tran) #1

Chào mọi người, mình đang sử dụng hocvps script và được biết muốn dùng 2 domain chạy chung 1 website thì sử dụng chức năng Park Domain.

Giờ mình đang có 1 website abc.com nhưng tên miền bị hết hạn nên mình muốn add 1 tên miền khác (xyz.com) để chạy website này.

Nhưng sau khi sử dụng chức năng Park Domain của hocvps script, mình gõ xyz.com nó lại redirect về tên miền cũ abc.com, mà tên miền cũ này đã hết hạn nên ko truy cập web được.

Mong mọi người giúp đỡ chỉ cho mình cách để chạy dc website trên domain mới. Xin cảm ơn rất nhiều!


(duy) #2

bạn bỏ redirect đi trong nginx config


(Việt Phương) #3

Hoặc bạn sửa trực tiếp trong Nginx Conf của domain cũ, sửa server_name với phần redirect


(Suke Tran) #4

Cảm ơn anh em đã giúp đỡ, mình có sửa lại Nginx Conf của domain cũ, thay server_name và phần rewrite thành domain mới, nhưng vẫn chưa thấy có gì thay đổi, hiện tại vẫn bị redirect về domain cũ. Có phải mình thiếu hay sai chỗ nào ko ?


(Việt Phương) #5

nginx restart/reload đc bình thường không bạn?
nginx -t


(Suke Tran) #6

Cảm ơn bác, em gõ thử lệnh service nginx restart thì có thông báo là

Redirecting to /bin/systemctl restart nginx.service

Em gà mờ nên ko hiểu là có bình thường ko, nhưng test thử thì có thông báo OK

nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

Nên bây giờ ko rõ là sai chỗ nào, mong bác chỉ giúp, em cảm ơn rất nhiều !


(duy) #7

bạn sửa file conf như thế nào, post ra đi bạn


(Suke Tran) #8

Trước tiên mình truy cập vào etc/nginx/conf.d/

Sau đó mở file .conf của domain cũ (9-food.net), domain mới mình muốn add là 9-foods.com

Và mình sửa lại như sau:

server {
	server_name www.9-foods.com;
	rewrite ^(.*) http://9-foods.com$1 permanent;
    	}
server {
	listen   80;

    	access_log off;
	# access_log /home//logs/access.log;
    	error_log off;
    	# error_log /home/9-food.net/logs/error.log;
    	root /home/9-food.net/public_html;
	index index.php index.html index.htm;
    	server_name 9-foods.com;
 
    	location / {
		try_files $uri $uri/ /index.php?$args;
	}
 
    	location ~ \.php$ {
		fastcgi_split_path_info ^(.+\.php)(/.+)$;
        	include /etc/nginx/fastcgi_params;
        	fastcgi_pass 127.0.0.1:9000;
        	fastcgi_index index.php;
		fastcgi_connect_timeout 300;
		fastcgi_send_timeout 300;
		fastcgi_read_timeout 300;
		fastcgi_buffer_size 32k;
		fastcgi_buffers 8 16k;
		fastcgi_busy_buffers_size 32k;
		fastcgi_temp_file_write_size 32k;
		fastcgi_intercept_errors on;
        	fastcgi_param SCRIPT_FILENAME /home/9-foods.com/public_html$fastcgi_script_name;
    	}
	location ~ /\. {
		deny all;
	}
	location = /favicon.ico {
		log_not_found off;
		access_log off;
	}
	location = /robots.txt {
		allow all;
		log_not_found off;
		access_log off;
	}
	location ~* \.(3gp|gif|jpg|jpeg|png|ico|wmv|avi|asf|asx|mpg|mpeg|mp4|pls|mp3|mid|wav|swf|flv|exe|zip|tar|rar|gz|tgz|bz2|uha|7z|doc|docx|xls|xlsx|pdf|iso|eot|svg|ttf|woff)$ {
		gzip_static off;
		add_header Pragma public;
		add_header Cache-Control "public, must-revalidate, proxy-revalidate";
		access_log off;
		expires 30d;
		break;
        }

        location ~* \.(txt|js|css)$ {
	        add_header Pragma public;
		add_header Cache-Control "public, must-revalidate, proxy-revalidate";
		access_log off;
		expires 30d;
		break;
        }
    }

Nhưng bây giờ khi truy cập 9-foods.com vẫn bị redirect về 9-food.net

Mong bạn giúp đỡ, cảm ơn bạn nhiều :smiley:


(Việt Phương) #9

Code này mình thấy bình thường. Trong conf.d không còn file nào quy định nữa chứ? Và nếu source code là WP thì bạn sửa permalink chưa?
Do hiện tại mình truy cập 9-foods.com thấy No input file specified. cơ :smiley:


(Suke Tran) #10

Cảm ơn bác, đúng là e dùng Wordpress là có lẽ lỗi permalink, nhưng bây giờ ko truy cập dc vào dashboard thì làm thế nào bác nhỉ ?


(Việt Phương) #11

Bạn sửa trong database ý. wp-options mục site url và home url


(Suke Tran) #12

Em update database rồi, wp_config cũng chèn thêm lệnh define mà khi truy cập vẫn bị báo No input file specified

Mệt mỏi kinh khủng hic. :sweat:

Bác nhiệt tình quá, cảm ơn bác rất nhiều !


(Việt Phương) #13

Thư mục home/9-food.net/public_html vẫn đầy đủ như ban đầu và đc đọc bởi nginx webserver chứ?


(Suke Tran) #14

Vâng thư mục đó vẫn đầy đủ bác ạ, em ko biết kiểm tra nginx webserver có đọc dc ko bằng cách nào :frowning:


(Việt Phương) #15

Nếu .conf, đặt trong thư mục /etc/nginx/conf,d, thuộc quyền sở hữu của nginx:nginx, có quyền read/write là hoàn toàn đọc đc
Về cơ bản là sửa trên file domain từ trc thì chắc chắn nginx đọc được
nginx -t lại bình thường tức file ý nginx bảo ok